Frequently Asked Question

Q. Why doesn't it work on my Android phone? (Hero / Galaxy / Spica / GW620)

A. Unfortunately, some Android smartphones still can't use Bluetooth functionality to transfer files. It happens mainly with Android 1.5 (Cupcake) and Android 1.6 (Donut). Please refer to our compatibility table and check if your mobile phone is currently supported or not by our application.

NOTE - starting from Android 2.0 (or above), the Bluetooth layer will work correctly, even with the unsupported phones!!!